Jangan menggunakan ubuntu 16.04 dengan serverpilot dulu

Beberapa saat yang lalu saya melakukan pindah server karena ip adresss server masuk ke spamhaus krn satu dan lain hal.

Digitalocean ada yang versi ubuntu terbaru yaitu 16.04. Review saya terhadap os versi ini hanya berdasarkan pengalaman pribadi.

Mysql versi terbaru ini menyebabkan beberapa masalah dengan date null atau 0000-00-00 00:00:00 . Menyebabkan rekord tidak bisa disave dan website saya yang phreebook untuk invoice2 semua tidak bisa dipakai.

Setelah saya utak atik, akhir nya saya bertanya kepada pihak support serverpilot dan dijawab oleh justin seperti ini

Hi Benny,

To disable strict SQL mode, take a look at our article here:

https://serverpilot.io/community/articles/how-to-disable-strict-mode-in-mysql-5-7.html

If you're still having problems because your app's code does not support MySQL 5.7, you should connect a new server that's running Ubuntu 14.04 because Ubuntu 14.04 uses MySQL 5.5.

Best,
Justin
ServerPilot Support

Check out our community for helpful articles and tutorials.
https://serverpilot.io/community/

Tetapi selain itu ada 1 masalah lagi pada website tokokristik.com yang menyebabkan saya langsung downgrade ke 14.04. Yaitu pada admin site tokokristik yang tidak berbentuk sehingga saya harus memakai 2 domain, yang satu untuk halaman depan dan yang halaman admin saya trik pakai domain gratisan .ga ....

Setelah saya pindah ke server baru, semua masalah selesai. Jadi kesimpulannya adalah jangan menggunakan versi 16.04 apabila coding website anda belum siap. Gunakan pada test server aja.

Terima kasih, semoga bermanfaat.

Comments